Announcement

Collapse
No announcement yet.

Lv 85 Armor quest bug stucked

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Lv 85 Armor quest bug stucked

    Hi, i have some problem when solving the quest. I have reinforced the armor for 5 times already. I remember and believe that she is telling me to put on the armor to get rid of the curse. However, no matter i put it on or not, nothing happens after i talk to her. and her lover still tells me that the lady is in south country. Can anyone please help to look at it? is it my problem or the quest's problem? I have attached some pics as well. THanks in advance.

  • #2
    Hyper123 in AECO you only need to reinforce if 3 times, 5 times would make the NPC won't repair it for you~
    Its not bug or quest problem .. its your problem~

    Comment


    • #3
      Originally posted by Naruchii- View Post
      Hyper123 in AECO you only need to reinforce if 3 times, 5 times would make the NPC won't repair it for you~
      Its not bug or quest problem .. its your problem~
      Thanks a lot bro. Coz it was 5 times back in the old days and wasnt sure how this server is update to. I just look at jap wiki it was changed to 3 times from 5 times in patch updated on 21/10/2010. but updates taken in 2012 is not valid in this server. Do you know where the server is at about?

      Comment


      • #4
        Hyper123 This server has its own update and not following any other server as references ...
        AECO even have its own exclusive Quest only available if you playing in this server ~

        Comment

        Working...
        X